Home Database Mysql Tutorial cisco NAT 的配置例子

cisco NAT 的配置例子

Jun 07, 2016 pm 03:06 PM
cisco nat s example Configuration

! version 12.0 service timestamps debug uptime service timestamps log uptime no service password-encryption ! hostname nat-r1 ! enable secret 5 $1$FEQr$INhRecYBeCb.UqTQ3b9mY0 ! ip subnet-zero ! ! ! ! interface Ethernet0 ip address 172.18.1


  !
  version 12.0
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname nat-r1
  !
  enable secret 5 $1$FEQr$INhRecYBeCb.UqTQ3b9mY0
  !
  ip subnet-zero
  !
   !
   !
   !
   interface Ethernet0
   ip address 172.18.150.150 255.255.0.0
   no ip directed-broadcast
   ip nat inside /* 定义此为网络的内部端口 */
  !
  interface Serial0
   ip address 192.1.1.161 255.255.255.252
   no ip directed-broadcast
   ip nat outside /* 定义此为网络的外部端口 */
  
   no ip mroute-cache
   no fair-queue
  !
  interface Serial1
   no ip address
   no ip directed-broadcast
   shutdown
  ! /* 定义从ISP那里申请到的IP在企业内部的分配策阅 */
  ip nat pool tech 192.1.1.100 192.1.1.120 netmask 255.255.255.0
  ip nat pool deve 192.1.1.121 192.1.1.150 netmask 255.255.255.0
  ip nat pool manager 192.1.1.180 192.1.1.200 netmask 255.255.255.0
  ip nat pool soft-1 192.1.1.170 192.1.1.179 netmask 255.255.255.0
  ip nat pool soft-2 192.1.1.151 192.1.1.159 netmask 255.255.255.0
  ip nat pool temp-user 192.1.1.160 192.1.1.160 netmask 255.255.255.0
   /* 将访问列表与地址池对应,以下为动态地址转换*/
  ip nat inside source list 1 pool tech
  ip nat inside source list 2 pool deve
  ip nat inside source list 3 pool manager
  ip nat inside source list 4 pool soft-1
  ip nat inside source list 5 pool soft-2
   /* 将访问列表与地址池对应,以下为复用动态地址转换*/
  ip nat inside source list 6 pool temp-user overload
   /* 将访问列表与地址池对应,以下为静态地址转换*/
  ip nat inside source static 172.18.100.168 192.1.1.168
  ip nat inside source static 172.18.100.169 192.1.1.169
  ip classless
  ip route 0.0.0.0 0.0.0.0 Serial0 /* 设置一个缺省路由 */
  ! /* 内部网访问地址表,他指出内部网络能访问外部网的地址段,
  分别定义是为了对应
   不同的地址池 */
  access-list 1 permit 172.18.107.0 0.0.0.255
  access-list 2 permit 172.18.101.0 0.0.0.255
  access-list 3 permit 172.18.108.0 0.0.0.255
  access-list 4 permit 172.18.103.0 0.0.0.255
  access-list 4 permit 172.18.102.0 0.0.0.255
  access-list 4 permit 172.18.104.0 0.0.0.255
  access-list 5 permit 172.18.105.0 0.0.0.255
  access-list 5 permit 172.18.106.0 0.0.0.255
  access-list 6 permit 172.18.111.0 0.0.0.255
  !
  line con 0
   transport input none
  line 1 16
  line aux 0
  line vty 0 4
   login
  !
  end
  
  

Statement of this Website
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

AI Hentai Generator

AI Hentai Generator

Generate AI Hentai for free.

Hot Article

R.E.P.O. Energy Crystals Explained and What They Do (Yellow Crystal)
3 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. Best Graphic Settings
3 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. How to Fix Audio if You Can't Hear Anyone
3 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
WWE 2K25: How To Unlock Everything In MyRise
3 weeks ago By 尊渡假赌尊渡假赌尊渡假赌

Hot Tools

Notepad++7.3.1

Notepad++7.3.1

Easy-to-use and free code editor

SublimeText3 Chinese version

SublimeText3 Chinese version

Chinese version, very easy to use

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

NAT Boost vs. Qos for games; which one is better? NAT Boost vs. Qos for games; which one is better? Feb 19, 2024 pm 07:00 PM

In today's situation where almost all games are online, it is not advisable to ignore the optimization of home network. Almost all routers are equipped with NATBoost and QoS features designed to enhance users' gaming experience. This article will explore the definition, advantages and disadvantages of NATBoost and QoS. NATBoost vs. Qos for games; which one is better? NATBoost, also known as Network Address Translation Boost, is a feature built into routers that improves their performance. It's especially important for gaming because it helps reduce network latency, which is the time it takes for data to be transferred between the gaming device and the server. By optimizing the data processing method within the router, NATBoost achieves faster data processing speed and lower latency, thus changing the

The perfect combination of PyCharm and PyTorch: detailed installation and configuration steps The perfect combination of PyCharm and PyTorch: detailed installation and configuration steps Feb 21, 2024 pm 12:00 PM

PyCharm is a powerful integrated development environment (IDE), and PyTorch is a popular open source framework in the field of deep learning. In the field of machine learning and deep learning, using PyCharm and PyTorch for development can greatly improve development efficiency and code quality. This article will introduce in detail how to install and configure PyTorch in PyCharm, and attach specific code examples to help readers better utilize the powerful functions of these two. Step 1: Install PyCharm and Python

The working principle and configuration method of GDM in Linux system The working principle and configuration method of GDM in Linux system Mar 01, 2024 pm 06:36 PM

Title: The working principle and configuration method of GDM in Linux systems In Linux operating systems, GDM (GNOMEDisplayManager) is a common display manager used to control graphical user interface (GUI) login and user session management. This article will introduce the working principle and configuration method of GDM, as well as provide specific code examples. 1. Working principle of GDM GDM is the display manager in the GNOME desktop environment. It is responsible for starting the X server and providing the login interface. The user enters

How to set up Git configuration in PyCharm How to set up Git configuration in PyCharm Feb 20, 2024 am 09:47 AM

Title: How to correctly configure Git in PyCharm In modern software development, the version control system is a very important tool, and Git, as one of the popular version control systems, provides developers with powerful functions and flexible operations. As a powerful Python integrated development environment, PyCharm comes with support for Git, allowing developers to manage code versions more conveniently. This article will introduce how to correctly configure Git in PyCharm to facilitate better development during the development process.

Understand Linux Bashrc: functions, configuration and usage Understand Linux Bashrc: functions, configuration and usage Mar 20, 2024 pm 03:30 PM

Understanding Linux Bashrc: Function, Configuration and Usage In Linux systems, Bashrc (BourneAgainShellruncommands) is a very important configuration file, which contains various commands and settings that are automatically run when the system starts. The Bashrc file is usually located in the user's home directory and is a hidden file. Its function is to customize the Bashshell environment for the user. 1. Bashrc function setting environment

Simple and easy-to-understand PyCharm configuration Git tutorial Simple and easy-to-understand PyCharm configuration Git tutorial Feb 20, 2024 am 08:28 AM

PyCharm is a commonly used integrated development environment (IDE). In daily development, using Git to manage code is essential. This article will introduce how to configure Git in PyCharm and use Git for code management, with specific code examples. Step 1: Install Git First, make sure Git is installed on your computer. If it is not installed, you can go to [Git official website](https://git-scm.com/) to download and install the latest version of Git

How to configure workgroup in win11 system How to configure workgroup in win11 system Feb 22, 2024 pm 09:50 PM

How to configure a workgroup in Win11 A workgroup is a way to connect multiple computers in a local area network, which allows files, printers, and other resources to be shared between computers. In Win11 system, configuring a workgroup is very simple, just follow the steps below. Step 1: Open the "Settings" application. First, click the "Start" button of the Win11 system, and then select the "Settings" application in the pop-up menu. You can also use the shortcut "Win+I" to open "Settings". Step 2: Select "System" In the Settings app, you will see multiple options. Please click the "System" option to enter the system settings page. Step 3: Select "About" In the "System" settings page, you will see multiple sub-options. Please click

MyBatis Generator configuration parameter interpretation and best practices MyBatis Generator configuration parameter interpretation and best practices Feb 23, 2024 am 09:51 AM

MyBatisGenerator is a code generation tool officially provided by MyBatis, which can help developers quickly generate JavaBeans, Mapper interfaces and XML mapping files that conform to the database table structure. In the process of using MyBatisGenerator for code generation, the setting of configuration parameters is crucial. This article will start from the perspective of configuration parameters and deeply explore the functions of MyBatisGenerator.

See all articles