VOIP的配置举例
复杂的VOIP 配置 一、 拓扑图 、中心 Zongbu#sh run Building configuration... Current configuration : 2216 bytes ! version 12.2 service timestamps debug uptime service timestamps log uptime no service password-encryption ! hostname Zongbu ! en
复杂的VOIP配置一、 拓扑图
、中心
Zongbu#sh run
Building configuration...
Current configuration : 2216 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Zongbu
!
enable password cisco
!
!
class-map match-all voice
match access-group 102
!
access-list 102 permit udp any any range 16384 32767
access-list 102 permit tcp any any eq 1720
access-list 102 permit tcp any eq 1720 any
!
policy-map qos
class voice
priority 40
class class-default
fair-queue
!
voice-card 1
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
!
!
!
!
!
controller E1 1/0
framing NO-CRC4
ds0-group 0 timeslots 17-31 type r2-digital r2-compelled
ds0-group 1 timeslots 1-15 type r2-digital r2-compelled
cas-custom 0
unused-abcd 0 0 1 1
country china
dnis-digits min 4 max 8
cas-custom 1
unused-abcd 0 0 1 1
country china
dnis-digits min 4 max 8
!
!
!
!
interface FastEthernet0/0
ip address 10.22.110.248 255.255.255.0
ip rip send version 2
duplex auto
speed auto
!
interface Serial0/0
description Connected to Fenzhi1
ip address 10.22.118.9 255.255.255.252
service-policy output qos
!
interface Serial0/1
description Connected to Fenzhi2
ip address 10.22.118.13 255.255.255.252
service-policy output qos
!
router ospf 100
log-adjacency-changes
redistribute static subnets
redistribute rip subnets
network 10.22.110.248 0.0.0.0 area 0
network 10.22.118.9 0.0.0.0 area 0
network 10.22.118.13 0.0.0.0 area 0
!
router rip
version 2
redistribute ospf 100 metric 2
network 10.0.0.0
default-metric 2
!
ip classless
ip route 10.0.0.0 255.0.0.0 10.22.110.253
ip route 10.22.108.0 255.255.255.0 10.22.110.254
ip route 10.22.109.0 255.255.255.0 10.22.110.254
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0:0
!
voice-port 1/0:1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 10 voip
description Phone to Fenzhi1
destination-pattern 6964....
session target ipv4:10.22.118.10
dtmf-relay cisco-rtp h245-signal h245-alphanumeric
fax rate 9600
!
dial-peer voice 20 voip
description Phone to Fenzhi2
destination-pattern 6962....
session target ipv4:10.22.118.14
dtmf-relay cisco-rtp h245-signal h245-alphanumeric
fax rate 9600
!
dial-peer voice 30 pots
destination-pattern 6491....
direct-inward-dial
port 1/0:0
!
dial-peer voice 40 pots
destination-pattern 1.
direct-inward-dial
port 1/0:1
forward-digits all
!
dial-peer voice 60 pots
destination-pattern 9481....
direct-inward-dial
port 1/0:0
forward-digits all
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
2、分支1
Fenzhi 1#sh run
Building configuration...
Current configuration : 1161 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Fenzhi1
!
enable password cisco
!
!
!
ip subnet-zero
!
class-map match-all voice
match access-group 102
!
access-list 102 permit udp any any range 16384 32767
access-list 102 permit tcp any any eq 1720
access-list 102 permit tcp any eq 1720 any
!
policy-map qos
class voice
priority 40
class class-default
fair-queue
!
!
!
interface Ethernet0/0
ip address 10.22.115.254 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 10.22.118.10 255.255.255.252
service-policy output qos
!
router ospf 100
log-adjacency-changes
network 10.22.115.254 0.0.0.0 area 0
network 10.22.118.10 0.0.0.0 area 0
!
ip classless
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 10 voip
destination-pattern 6491....
session target ipv4:10.22.118.9
dtmf-relay cisco-rtp h245-signal h245-alphanumeric
fax rate 9600
!
dial-peer voice 20 pots
preference 2
destination-pattern 6964....
port 1/0/0
!
dial-peer voice 30 pots
preference 5
destination-pattern 6964....
port 1/0/1
!
dial-peer voice 40 voip
destination-pattern 6962....
session target ipv4:10.22.118.14
dtmf-relay cisco-rtp h245-signal h245-alphanumeric
fax rate 9600
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

Hot AI Tools

Undresser.AI Undress
AI-powered app for creating realistic nude photos

AI Clothes Remover
Online AI tool for removing clothes from photos.

Undress AI Tool
Undress images for free

Clothoff.io
AI clothes remover

AI Hentai Generator
Generate AI Hentai for free.

Hot Article

Hot Tools

Notepad++7.3.1
Easy-to-use and free code editor

SublimeText3 Chinese version
Chinese version, very easy to use

Zend Studio 13.0.1
Powerful PHP integrated development environment

Dreamweaver CS6
Visual web development tools

SublimeText3 Mac version
God-level code editing software (SublimeText3)

Hot Topics

Title: The working principle and configuration method of GDM in Linux systems In Linux operating systems, GDM (GNOMEDisplayManager) is a common display manager used to control graphical user interface (GUI) login and user session management. This article will introduce the working principle and configuration method of GDM, as well as provide specific code examples. 1. Working principle of GDM GDM is the display manager in the GNOME desktop environment. It is responsible for starting the X server and providing the login interface. The user enters

Title: How to correctly configure Git in PyCharm In modern software development, the version control system is a very important tool, and Git, as one of the popular version control systems, provides developers with powerful functions and flexible operations. As a powerful Python integrated development environment, PyCharm comes with support for Git, allowing developers to manage code versions more conveniently. This article will introduce how to correctly configure Git in PyCharm to facilitate better development during the development process.

PyCharm is a powerful integrated development environment (IDE), and PyTorch is a popular open source framework in the field of deep learning. In the field of machine learning and deep learning, using PyCharm and PyTorch for development can greatly improve development efficiency and code quality. This article will introduce in detail how to install and configure PyTorch in PyCharm, and attach specific code examples to help readers better utilize the powerful functions of these two. Step 1: Install PyCharm and Python

Understanding Linux Bashrc: Function, Configuration and Usage In Linux systems, Bashrc (BourneAgainShellruncommands) is a very important configuration file, which contains various commands and settings that are automatically run when the system starts. The Bashrc file is usually located in the user's home directory and is a hidden file. Its function is to customize the Bashshell environment for the user. 1. Bashrc function setting environment

PyCharm is a commonly used integrated development environment (IDE). In daily development, using Git to manage code is essential. This article will introduce how to configure Git in PyCharm and use Git for code management, with specific code examples. Step 1: Install Git First, make sure Git is installed on your computer. If it is not installed, you can go to [Git official website](https://git-scm.com/) to download and install the latest version of Git

MyBatisGenerator is a code generation tool officially provided by MyBatis, which can help developers quickly generate JavaBeans, Mapper interfaces and XML mapping files that conform to the database table structure. In the process of using MyBatisGenerator for code generation, the setting of configuration parameters is crucial. This article will start from the perspective of configuration parameters and deeply explore the functions of MyBatisGenerator.

How to configure a workgroup in Win11 A workgroup is a way to connect multiple computers in a local area network, which allows files, printers, and other resources to be shared between computers. In Win11 system, configuring a workgroup is very simple, just follow the steps below. Step 1: Open the "Settings" application. First, click the "Start" button of the Win11 system, and then select the "Settings" application in the pop-up menu. You can also use the shortcut "Win+I" to open "Settings". Step 2: Select "System" In the Settings app, you will see multiple options. Please click the "System" option to enter the system settings page. Step 3: Select "About" In the "System" settings page, you will see multiple sub-options. Please click

Flask installation and configuration tutorial: A tool to easily build Python Web applications, specific code examples are required. Introduction: With the increasing popularity of Python, Web development has become one of the necessary skills for Python programmers. To carry out web development in Python, we need to choose a suitable web framework. Among the many Python Web frameworks, Flask is a simple, easy-to-use and flexible framework that is favored by developers. This article will introduce the installation of Flask framework,
