Home Database Mysql Tutorial Oracle for AIX基于裸设备的表空间扩充步聚

Oracle for AIX基于裸设备的表空间扩充步聚

Jun 07, 2016 pm 05:20 PM
oracle

查看已有VG #lsvg rootvg oravg datavg 查看每个VG使用状态 #lsvg oravg 重点关注几个值 PP SIZE: 512 megabyte(s)

查看已有VG

#lsvg

rootvg

oravg

datavg

 

查看每个VG使用状态

#lsvg oravg

重点关注几个值

PP SIZE:        512 megabyte(s)      注释:每个PP大小

FREE PPs:      147 (75264 megabytes) 注释:剩余pp数及空间大小

#lsvg datavg

PP SIZE:        512 megabyte(s)

FREE PPs:      3974 (2034688 megabytes)

 

查看当前lv建立的数目

#lsvg -l rootvg  注释:rootvg上面没有关于数据库的lv

#lsvg -l oravg

...........        ...        ...  ...  .    ..........    ...

lv_users_49        raw        128  128  1    open/syncd    N/A

lv_users_50        raw        128  128  1    open/syncd    N/A

lv_users_51        raw        128  128  1    open/syncd    N/A

lv_users_52        raw        128  128  2    open/syncd    N/A

 

#lsvg -l datavg

datavg:

LV NAME            TYPE      LPs  PPs  PVs  LV STATE      MOUNT POINT

lv_users_53        raw        128  128  1    open/syncd    N/A

lv_users_54        raw        128  128  1    open/syncd    N/A

lv_users_55        raw        128  128  1    open/syncd    N/A

lv_users_56        raw        128  128  1    open/syncd    N/A

lv_users_57        raw        128  128  1    open/syncd    N/A

lv_users_58        raw        128  128  1    open/syncd    N/A

lv_users_59        raw        128  128  1    open/syncd    N/A

lv_users_60        raw        128  128  1    open/syncd    N/A

 

查看完成后,新的lv从lv_users_61开始建

 

例如:

在oravg下建十块lv,每块大小64g,名字为

lv_users_61 lv_users_62 lv_users_63  ... ...  lv_users_64

PP_Size=512M,64G/PP_Size=128(NumPPs)

 

命令格式:

"/usr/sbin/mklv -y LVname -T O -w n -s n -r n VGname NumPPs"

#mklv -y lv_users_61 -t 'raw' -T O -w n -s n -r n datavg 128

#mklv -y lv_users_62 -t 'raw' -T O -w n -s n -r n datavg 128

#mklv -y lv_users_63 -t 'raw' -T O -w n -s n -r n datavg 128

... ...

#mklv -y lv_users_70 -t 'raw' -T O -w n -s n -r n datavg 128

 

修改rlv块设备权限

#cd /dev/

#ls -l rlv_user_60 查看以前块设备权限

#ls -l rlv_user_61 查看刚才新建的块设备权限

#chown Oracle:dba rlv_user_61

#chown oracle:dba rlv_user_62

#chown oracle:dba rlv_user_63

... ...

#chown oracle:dba rlv_user_70

 

然后加到表空间 Usersoracle加空间命令

#su - oracle

$sqlplus /nolog

$conn sys/oracle as sysdba;

进入sqlplus

>ALTER TABLESPACE "USERS" ADD DATAFILE '/dev/rlv_users_61' SIZE 65500M REUSE;

>ALTER TABLESPACE "USERS" ADD DATAFILE '/dev/rlv_users_62' SIZE 65500M REUSE;

>ALTER TABLESPACE "USERS" ADD DATAFILE '/dev/rlv_users_63' SIZE 65500M REUSE;

... ...

>ALTER TABLESPACE "USERS" ADD DATAFILE '/dev/rlv_users_70' SIZE 65500M REUSE;

逐个添加,输入加空间命令之后耐心等待,直至出现添加成功的提示之后方可输入下一条

添加命令。

添加完成后检查表空间,,确认添加已经成功!

linux

Statement of this Website
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

AI Hentai Generator

AI Hentai Generator

Generate AI Hentai for free.

Hot Article

R.E.P.O. Energy Crystals Explained and What They Do (Yellow Crystal)
2 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
Repo: How To Revive Teammates
1 months ago By 尊渡假赌尊渡假赌尊渡假赌
Hello Kitty Island Adventure: How To Get Giant Seeds
1 months ago By 尊渡假赌尊渡假赌尊渡假赌

Hot Tools

Notepad++7.3.1

Notepad++7.3.1

Easy-to-use and free code editor

SublimeText3 Chinese version

SublimeText3 Chinese version

Chinese version, very easy to use

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

How long will Oracle database logs be kept? How long will Oracle database logs be kept? May 10, 2024 am 03:27 AM

The retention period of Oracle database logs depends on the log type and configuration, including: Redo logs: determined by the maximum size configured with the "LOG_ARCHIVE_DEST" parameter. Archived redo logs: Determined by the maximum size configured by the "DB_RECOVERY_FILE_DEST_SIZE" parameter. Online redo logs: not archived, lost when the database is restarted, and the retention period is consistent with the instance running time. Audit log: Configured by the "AUDIT_TRAIL" parameter, retained for 30 days by default.

Function to calculate the number of days between two dates in oracle Function to calculate the number of days between two dates in oracle May 08, 2024 pm 07:45 PM

The function in Oracle to calculate the number of days between two dates is DATEDIFF(). The specific usage is as follows: Specify the time interval unit: interval (such as day, month, year) Specify two date values: date1 and date2DATEDIFF(interval, date1, date2) Return the difference in days

The order of the oracle database startup steps is The order of the oracle database startup steps is May 10, 2024 am 01:48 AM

The Oracle database startup sequence is: 1. Check the preconditions; 2. Start the listener; 3. Start the database instance; 4. Wait for the database to open; 5. Connect to the database; 6. Verify the database status; 7. Enable the service (if necessary ); 8. Test the connection.

How to use interval in oracle How to use interval in oracle May 08, 2024 pm 07:54 PM

The INTERVAL data type in Oracle is used to represent time intervals. The syntax is INTERVAL <precision> <unit>. You can use addition, subtraction, multiplication and division operations to operate INTERVAL, which is suitable for scenarios such as storing time data and calculating date differences.

How much memory does oracle require? How much memory does oracle require? May 10, 2024 am 04:12 AM

The amount of memory required by Oracle depends on database size, activity level, and required performance level: for storing data buffers, index buffers, executing SQL statements, and managing the data dictionary cache. The exact amount is affected by database size, activity level, and required performance level. Best practices include setting the appropriate SGA size, sizing SGA components, using AMM, and monitoring memory usage.

How to see the number of occurrences of a certain character in Oracle How to see the number of occurrences of a certain character in Oracle May 09, 2024 pm 09:33 PM

To find the number of occurrences of a character in Oracle, perform the following steps: Get the total length of a string; Get the length of the substring in which a character occurs; Count the number of occurrences of a character by subtracting the substring length from the total length.

Oracle database server hardware configuration requirements Oracle database server hardware configuration requirements May 10, 2024 am 04:00 AM

Oracle database server hardware configuration requirements: Processor: multi-core, with a main frequency of at least 2.5 GHz. For large databases, 32 cores or more are recommended. Memory: At least 8GB for small databases, 16-64GB for medium sizes, up to 512GB or more for large databases or heavy workloads. Storage: SSD or NVMe disks, RAID arrays for redundancy and performance. Network: High-speed network (10GbE or higher), dedicated network card, low-latency network. Others: Stable power supply, redundant components, compatible operating system and software, heat dissipation and cooling system.

How to replace string in oracle How to replace string in oracle May 08, 2024 pm 07:24 PM

The method of replacing strings in Oracle is to use the REPLACE function. The syntax of this function is: REPLACE(string, search_string, replace_string). Usage steps: 1. Identify the substring to be replaced; 2. Determine the new string to replace the substring; 3. Use the REPLACE function to replace. Advanced usage includes: multiple replacements, case sensitivity, special character replacement, etc.

See all articles