Home Java javaTutorial Example of implementing a digital black hole in Java

Example of implementing a digital black hole in Java

Sep 14, 2017 am 10:12 AM
java Example black hole

This article mainly introduces how to implement the digital black hole algorithm game in Java programming, which involves basic knowledge of Java programming such as arrays, scanners, and if statements. Friends in need can refer to the following

Given any For a 4-digit positive integer with different digits, if we first sort the 4 numbers non-increasingly, then non-decreasingly, and then subtract the second number from the first number, we will get a new number. If we keep doing this repeatedly, we will soon stop at 6174, which is known as the "digital black hole". This magical number is also called the Kaprekar constant.

For example, we start from 6767, we will get

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174

Now given any 4-digit positive integer, please write a program to demonstrate the process of reaching the black hole.

Input format:

The input gives a positive integer N in the interval (0, 10000).

Output format:

If the 4 digits of N are all equal, output "N - N = 0000" in one line; otherwise Output each step of the calculation in one line until 6174 appears as the difference. See the example for the output format. Note that each number is output in 4-digit format.

Input sample 1:

6767

Output sample 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Input sample 2:

2222

Output sample 2:

2222 - 2222 = 0000

The specific code is as follows:


import java.util.Arrays; 
import java.util.Scanner; 
public class Main { 
  public static void main(String args[]) { 
    Scanner sc = new Scanner(System.in); 
    int x = sc.nextInt(); 
    int ans = ds(x)-xs(x); 
    if(ans==0){ 
      System.out.printf("%04d - %04d = %04d\n",ds(x),xs(x),ans); 
    }else{ 
      int n ; 
      do{ 
        n = ds(x)-xs(x); 
        System.out.printf("%04d - %04d = %04d\n",ds(x),xs(x),n); 
        x = n; 
      }while(n!=6174); 
    } 
  } 
  public static int ds (int x){ 
    int[]a = new int[4]; 
    a[0] = x/1000; 
    a[1] = x/100%10; 
    a[2] = x/10%10; 
    a[3] = x%10; 
    Arrays.sort(a); 
    int sum = a[3]*1000+a[2]*100+a[1]*10+a[0]; 
    return sum; 
  } 
  public static int xs (int x){ 
    int[]a = new int[4]; 
    a[0] = x/1000; 
    a[1] = x/100%10; 
    a[2] = x/10%10; 
    a[3] = x%10; 
    Arrays.sort(a); 
    int sum = a[0]*1000+a[1]*100+a[2]*10+a[3]; 
    return sum; 
  } 
}
Copy after login

The output is as follows:


4695
9654 - 4569 = 5085
8550 - 0558 = 7992
9972 - 2799 = 7173
7731 - 1377 = 6354
6543 - 3456 = 3087
8730 - 0378 = 8352
8532 - 2358 = 6174
Copy after login

Summary

The above is the detailed content of Example of implementing a digital black hole in Java. For more information, please follow other related articles on the PHP Chinese website!

Statement of this Website
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn

Hot AI Tools

Undresser.AI Undress

Undresser.AI Undress

AI-powered app for creating realistic nude photos

AI Clothes Remover

AI Clothes Remover

Online AI tool for removing clothes from photos.

Undress AI Tool

Undress AI Tool

Undress images for free

Clothoff.io

Clothoff.io

AI clothes remover

AI Hentai Generator

AI Hentai Generator

Generate AI Hentai for free.

Hot Article

R.E.P.O. Energy Crystals Explained and What They Do (Yellow Crystal)
4 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. Best Graphic Settings
4 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
R.E.P.O. How to Fix Audio if You Can't Hear Anyone
4 weeks ago By 尊渡假赌尊渡假赌尊渡假赌
WWE 2K25: How To Unlock Everything In MyRise
1 months ago By 尊渡假赌尊渡假赌尊渡假赌

Hot Tools

Notepad++7.3.1

Notepad++7.3.1

Easy-to-use and free code editor

SublimeText3 Chinese version

SublimeText3 Chinese version

Chinese version, very easy to use

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

Perfect Number in Java Perfect Number in Java Aug 30, 2024 pm 04:28 PM

Guide to Perfect Number in Java. Here we discuss the Definition, How to check Perfect number in Java?, examples with code implementation.

Random Number Generator in Java Random Number Generator in Java Aug 30, 2024 pm 04:27 PM

Guide to Random Number Generator in Java. Here we discuss Functions in Java with examples and two different Generators with ther examples.

Weka in Java Weka in Java Aug 30, 2024 pm 04:28 PM

Guide to Weka in Java. Here we discuss the Introduction, how to use weka java, the type of platform, and advantages with examples.

Smith Number in Java Smith Number in Java Aug 30, 2024 pm 04:28 PM

Guide to Smith Number in Java. Here we discuss the Definition, How to check smith number in Java? example with code implementation.

Java Spring Interview Questions Java Spring Interview Questions Aug 30, 2024 pm 04:29 PM

In this article, we have kept the most asked Java Spring Interview Questions with their detailed answers. So that you can crack the interview.

Break or return from Java 8 stream forEach? Break or return from Java 8 stream forEach? Feb 07, 2025 pm 12:09 PM

Java 8 introduces the Stream API, providing a powerful and expressive way to process data collections. However, a common question when using Stream is: How to break or return from a forEach operation? Traditional loops allow for early interruption or return, but Stream's forEach method does not directly support this method. This article will explain the reasons and explore alternative methods for implementing premature termination in Stream processing systems. Further reading: Java Stream API improvements Understand Stream forEach The forEach method is a terminal operation that performs one operation on each element in the Stream. Its design intention is

TimeStamp to Date in Java TimeStamp to Date in Java Aug 30, 2024 pm 04:28 PM

Guide to TimeStamp to Date in Java. Here we also discuss the introduction and how to convert timestamp to date in java along with examples.

Java Program to Find the Volume of Capsule Java Program to Find the Volume of Capsule Feb 07, 2025 am 11:37 AM

Capsules are three-dimensional geometric figures, composed of a cylinder and a hemisphere at both ends. The volume of the capsule can be calculated by adding the volume of the cylinder and the volume of the hemisphere at both ends. This tutorial will discuss how to calculate the volume of a given capsule in Java using different methods. Capsule volume formula The formula for capsule volume is as follows: Capsule volume = Cylindrical volume Volume Two hemisphere volume in, r: The radius of the hemisphere. h: The height of the cylinder (excluding the hemisphere). Example 1 enter Radius = 5 units Height = 10 units Output Volume = 1570.8 cubic units explain Calculate volume using formula: Volume = π × r2 × h (4

See all articles