Home Java javaTutorial How to calculate the sum of a sequence in java

How to calculate the sum of a sequence in java

Nov 25, 2019 pm 05:55 PM
java method

How to calculate the sum of a sequence in java

Title description:

Input n and a, find a aa aaa...aa...a (n a), for example, when n=3, a=2 , the result of 2 22 222 is 246.

java related video tutorial: java teaching video

Input:

contains two integers, n and a, the meaning is as above, you can assume n and a are both non-negative integers less than 10

Output:

Output the sum of the first n terms, occupy a separate line

Sample input:

3 2
Copy after login

Sample output:

246
Copy after login

Program code:

import java.util.*;
public class Main
{
	public static void main(String[] args)
	{
		Scanner input=new Scanner(System.in);
		int n=input.nextInt();
		int x=input.nextInt();
		int sum=0,b=x;
		for(int i=1;i<=n;i++)
		{
			sum+=x;
			x=x*10+b;
		}
		System.out.println(sum);
	}
}
Copy after login

For more related articles, please visit: Introduction to java development

The above is the detailed content of How to calculate the sum of a sequence in java. For more information, please follow other related articles on the PHP Chinese website!

Statement of this Website
The content of this article is voluntarily contributed by netizens, and the copyright belongs to the original author. This site does not assume corresponding legal responsibility. If you find any content suspected of plagiarism or infringement, please contact admin@php.cn

Hot Article Tags

Notepad++7.3.1

Notepad++7.3.1

Easy-to-use and free code editor

SublimeText3 Chinese version

SublimeText3 Chinese version

Chinese version, very easy to use

Zend Studio 13.0.1

Zend Studio 13.0.1

Powerful PHP integrated development environment

Dreamweaver CS6

Dreamweaver CS6

Visual web development tools

SublimeText3 Mac version

SublimeText3 Mac version

God-level code editing software (SublimeText3)

Square Root in Java Square Root in Java Aug 30, 2024 pm 04:26 PM

Square Root in Java

Perfect Number in Java Perfect Number in Java Aug 30, 2024 pm 04:28 PM

Perfect Number in Java

Random Number Generator in Java Random Number Generator in Java Aug 30, 2024 pm 04:27 PM

Random Number Generator in Java

Armstrong Number in Java Armstrong Number in Java Aug 30, 2024 pm 04:26 PM

Armstrong Number in Java

Weka in Java Weka in Java Aug 30, 2024 pm 04:28 PM

Weka in Java

Smith Number in Java Smith Number in Java Aug 30, 2024 pm 04:28 PM

Smith Number in Java

Java Spring Interview Questions Java Spring Interview Questions Aug 30, 2024 pm 04:29 PM

Java Spring Interview Questions

Break or return from Java 8 stream forEach? Break or return from Java 8 stream forEach? Feb 07, 2025 pm 12:09 PM

Break or return from Java 8 stream forEach?

See all articles